4066 Schalter - Problem

Probleme mit einer Schaltung? Hier kann geholfen werden

Moderator: dussel07

4066 Schalter - Problem

Beitragvon Flub » 27.07.2010, 21:17

Hallo,
Ich habe folgendes Problem mit dem 4066 analog schalter und komme einfach nicht weiter, vielleicht könnt ihr mir helfen:
An Pin acht liegt ein Dreieck signal mit der Amplitude 0,4 V an. An Pin 6 eine pulsierende gleichspannung die zwischen 0 und 5 volt wechselt. außerdem ist pin 6 mit pin 5 verbunden, weil dasselbe steuersignal nochmal gebraucht wird. Alles funktioniert einwandfrei, nur an pin 9 messe ich durchgehend 0,4V. Hat jemand eine Idee, was das sein könnte? ich hab mit dem Multimeter schon nachgemessen, ob pin 9 mit irgendetwas irrtümlich verbunden ist, so ist es nicht.
Bild

Viele Grüße,
Flo
Flub
 

Re: 4066 Schalter - Problem

Beitragvon Chef » 27.07.2010, 21:26

Hast du den Ausgang einmal mit einem Widerstand belastet?

Chef :D
Wenn es die Elektronik nicht gäbe, müsste man sie erfinden.
Benutzeravatar
Chef
Site Admin
 
Beiträge: 2697
Registriert: 04.11.2008, 17:56
Wohnort: Hamburg

Re: 4066 Schalter - Problem

Beitragvon Flub » 27.07.2010, 21:30

meinst du, dass man noch einen spannungsabfall braucht = ) ich versuchs mal, mit 100k auf masse.
EDIT: hat leider nichts gebracht, wichtig ist zu sagen, dass auch keine gleichspannung sondern 0 V an 9 liegen. das steuer signal wechselt zwischen 5V und 0V bei schalter B und C und bei A und D zwischen 10V und 0V.
Flub
 

Re: 4066 Schalter - Problem

Beitragvon alterhase » 27.07.2010, 21:44

Kannst du den 4066er tauschen oder hast du die Sockel eingespart?
73 55
alterhase
 
Beiträge: 10194
Registriert: 14.11.2008, 08:58
Wohnort: Wien/Kapfenberg

Re: 4066 Schalter - Problem

Beitragvon Flub » 27.07.2010, 21:49

ich kann den 4066 tauschen. hab ich auch schon gemacht, leider derselbe fehler.

Also, mir fällt gerade auf das schalter b und c beide nicht richtig funktionieren.
Kann es ein Problem sein, dass das steuersignal bei schalter A und D auf 10 V geht zum öffnen und das von B und C nur auf 5V ?

An Pin 8 liegt ein Dreieck signal mit der Amplitude 0,4 V an.
Flub
 

Re: 4066 Schalter - Problem

Beitragvon alterhase » 27.07.2010, 21:50

Flub hat geschrieben:ich kann den 4066 tauschen. hab ich auch schon gemacht, leider derselbe fehler.

Also, mir fällt gerade auf das schalter b und c beide nicht richtig funktionieren.
Kann es ein Problem sein, dass das steuersignal bei schalter A und D auf 10 V geht zum öffnen und das von B und C nur auf 5V ?


so wird es sein! bei VDD 10V ist 5V Verbotener Bereich.

Faustformel:
Low = < 1/3 VDD
High = > 2/3 VDD
73 55
alterhase
 
Beiträge: 10194
Registriert: 14.11.2008, 08:58
Wohnort: Wien/Kapfenberg

Re: 4066 Schalter - Problem

Beitragvon Flub » 28.07.2010, 08:16

das wars so halb :wink: irgendwie funktioiniert immer nur einer der beiden schalter gut, also einer der beiden die mit einem steursignal geöffnet und geschlossen werden. kann es damit zusammenhängen, dass dasselbe signal einmal durch den einen schalter durch einen invertierenden verstärker geht und gleich durch den nächsten schalter soll?
EDIT: die steuersignale unterschieden sich jetzt noch noch um +-0,1V um 10 V (VDD ist 15V)
Flub
 

Re: 4066 Schalter - Problem

Beitragvon finn » 28.07.2010, 08:29

10V(bei 15V) ist auch schon grenzwertig...
zumindest, wenn man der faustregel folgt ^^
finn
 

Re: 4066 Schalter - Problem

Beitragvon Flub » 28.07.2010, 08:36

aber warum schaltet dann jeweils von einem steuersignal ein schalter perfekt und der andere mit selbem signal gar nicht oder ganz verkorkst? ich hab echt keine ahnung was das sein könnte ...

edit: ich versuch das jetzt aber mal wirklich mit deutlich mehr als 10 V was ja nach der faustregel gerade so ausreichen sollte.
Flub
 

Re: 4066 Schalter - Problem

Beitragvon Flub » 28.07.2010, 09:34

kann es sein das germanium spitzendioden (die hab ich zum testen bis die schottky dioden da sind) ab 10 V auch gegen die durchlassrichtung leiten?
Flub
 

Re: 4066 Schalter - Problem

Beitragvon alterhase » 28.07.2010, 09:52

Flub hat geschrieben:kann es sein das germanium spitzendioden (die hab ich zum testen bis die schottky dioden da sind) ab 10 V auch gegen die durchlassrichtung leiten?


Das sagt dir das Datenblatt. Jedenfalls hat Ge. einen wesentlich größeren I R = Leckstrom in Sperrrichtung. Eine AA119 hat zB. ca. 3µA bei 3V.
73 55
alterhase
 
Beiträge: 10194
Registriert: 14.11.2008, 08:58
Wohnort: Wien/Kapfenberg


Zurück zu Grundlagen

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 2 Gäste

cron