LM317 rauscht.

Wenn ihr was über bestimmte Bauteile wissen wollt

Moderator: dussel07

LM317 rauscht.

Beitragvon Mathias » 23.11.2016, 18:19

Ich wollte ein einfache Spannungsregelung für meinen AD-Wandler machen, welche die 5V von einem USB-Ausgang auf ca. 3V runteregelt.
Nun muss ich leider feststellen, das die 3V mehr rauschen als die knapp 5V vom USB.
An den 3V habe ich extra einen 100uF Elko, neben einem 100nF Kondensator angeschlossen.

Kann man da etwas dagegen tun, was für ein Spannungsregler könnt ihr mir empfehlen ?

Das Rauschen sieht man sofort, an einer Messsonde, welche als Spannungsteiler an den 3V betrieben wird.

Das ich überhaupt eine externe Regelung gemacht habe liegt daran, das bei meinem Original-Ardunio-Nano die 3.3V sehr stabil waren.
Nun habe ich diesen nicht mehr, sondern nur noch China-Modelle, aber bei denen rauscht der 3.3V-Ausgang. Aber der LM317 ist noch schlimmer.
Mathias
 
Beiträge: 148
Registriert: 14.04.2016, 17:23
Wohnort: Zürcher Oberland

Re: LM317 rauscht.

Beitragvon frank_w » 24.11.2016, 11:19

poste doch mal deine Schaltung hier.

Gruß Frank
frank_w
 
Beiträge: 508
Registriert: 22.03.2012, 07:59
Wohnort: Herzberg/E

Re: LM317 rauscht.

Beitragvon alterhase » 24.11.2016, 17:22

3,3V aus 5V geht nicht der 317er braucht min. 3V drop (= VIN - VOUT) sonst kann er nicht. ...zumal auf den 5V auch noch neg. Spikes sein werden.

Ist es ein Rauschen oder ein Ripple? Oszillogramme?

:arrow: Ein großes C am Ausgang des Stabis ist eher kontraproduktiv.
In den Datenblättern wird ein C von 10µF vom Adj. Pin gegen GND empfohlen.

:arrow: Auch hat der 317er einen Mindestlaststrom, der aber in den meisten Fällen durch den Spannungsteiler sichergestellt wird.

:arrow: Schau ins Datenblatt des LM317 von LT, dort sind auch Angaben über die richtige Leitungsführung.

:idea: Mach dich schlau über Shuntregulatoren. Die werden wohl das Mittel deiner Wahl werden.

:wink: Ansonsten wirken LC Filter in den Speiseleitungen oft Wunder.
Löten verbindet ...manchmals. :mrgreen:
73 55
alterhase
 
Beiträge: 12046
Registriert: 14.11.2008, 08:58
Wohnort: Wien/Kapfenberg

Re: LM317 rauscht.

Beitragvon Mathias » 24.11.2016, 19:59

poste doch mal deine Schaltung hier.

Die Schaltung sieht etw so aus:
Bild


3,3V aus 5V geht nicht der 317er braucht min. 3V drop (= VIN - VOUT) sonst kann er nicht. ...zumal auf den 5V auch noch neg. Spikes sein werden.

Dann wird dies das Problem sein.

Recht-Oben, sieht man das rauschen gut.
Bei einer stabilen Spannung, gibt es eine saubere Treppe.

Mach dich schlau über Shuntregulatoren. Die werden wohl das Mittel deiner Wahl werden.

Ich werde mal googlen.

Wie würde es mit einem LF33CF aussehen, der fängt bei der Eingangsspannung mit -0.5V an. Wie das mit -0.5V funktioniert. keine Ahnung.
http://cdn-reichelt.de/documents/datenblatt/A200/LF33CDT_LF33CV_LF50CV%23STM.pdf
Dateianhänge
Messwert_000000-1.pdf
(15.61 KiB) 76-mal heruntergeladen
Mathias
 
Beiträge: 148
Registriert: 14.04.2016, 17:23
Wohnort: Zürcher Oberland

Re: LM317 rauscht.

Beitragvon alterhase » 25.11.2016, 08:03

Ich hab da etwa an einen LM431 gedacht. ...weil W&W-Typ.

low-Drop-Regler sind biestig vonwegen Schwingen. ...ich mag sie nicht.

Deine 5V werden vermutlich auch stabilisiert sein. ...oder kommen die aus einem (Chinateil) SNT
Dann wäre es besser die ? Eingangsspannung des 5V Stabi auch dem LM317 anzubieten.

Du hast ja ein gutes altes Analogscope, wenn ich mich nicht irre. :wink:
Stell den Eingang auf AC und sieh dir den Ripple vor und nach dem 317er an. Dann lege die 10µ parallel zum 390Ω und gib ausgangsseitig 1µ Tantal.
Den 240Ω lege ganz nahe an den Ausgangspin. so, dass der Ausgangsstrom und der Referenzstrom sich kein Stück Leitung teilen müssen.
Löten verbindet ...manchmals. :mrgreen:
73 55
alterhase
 
Beiträge: 12046
Registriert: 14.11.2008, 08:58
Wohnort: Wien/Kapfenberg

Re: LM317 rauscht.

Beitragvon Mathias » 25.11.2016, 17:50

Deine 5V werden vermutlich auch stabilisiert sein.

Ich nehme mal an, die kommen vom PC Mainboard. Und die Leitungen und der HUB haben auch noch Innenwiderstand.
Das diese Spannung schlecht kommt, dafür brauche ich nicht mal einen KO. Ich habe eine LED-Laufschrift mit blauen LEDs gebaut, und dies flackern auch, je nach, wie der PC belastet ist. Wen der PC auf Standby ist, werden die LEDs einiges heller.
Und mit meinem Mess-Programm sieht man das auch, immerhin macht dies über 400 Messungen/Sekunde.

Am VGA-Ausgang meiner GeForce habe ich auch einen 5V-Pin, dieser ist erstaunlicherweise sehr stabil. Wen ich diesen zum Messen nehme, habe ich fast eine gerade Linie. Mein alter Arduino Nano hatte an den 3,3V auch ein sehr sauberes Signal, welches aus den UART (FT232R) kam.
Aber die China-Modelle habe einen 340 als UART verbaut, und dieser rausch auch, aber nicht so schlimm wie der LM317.

Dann lege die 10µ parallel zum 390Ω und gib ausgangsseitig 1µ Tantal.
Den 240Ω lege ganz nahe an den Ausgangspin. so, dass der Ausgangsstrom und der Referenzstrom sich kein Stück Leitung teilen müssen.

Dies werde ich mal bei Gelegenheit probieren. Ist es bei Kondensator wichtig, das die ein Tantal ist ?

Hast du das mit den 10µ so gemeint, wie bei dieser Schaltung ?

Bild
Mathias
 
Beiträge: 148
Registriert: 14.04.2016, 17:23
Wohnort: Zürcher Oberland

Re: LM317 rauscht.

Beitragvon alterhase » 25.11.2016, 18:22

Kitzle dir die 12V aus dem MB und mach daraus die 3,3V und alles wird gut. 8)


...Bild...
...wenn dein Bild auch mein Bild ist. ... genau so! :mrgreen: einfach parallel zum 390R :wink:

Ja! Tantal hat einen sehr niedrigen ESR ...verträgt deshalb aber keine schnellen Anstiegszeiten. (ist aber heutzutage auch kein echtes Problem mehr)
Löten verbindet ...manchmals. :mrgreen:
73 55
alterhase
 
Beiträge: 12046
Registriert: 14.11.2008, 08:58
Wohnort: Wien/Kapfenberg

Re: LM317 rauscht.

Beitragvon Mathias » 25.11.2016, 20:48

Jetzt sollte ein Bild ersichtlich sein. :wink:
Mathias
 
Beiträge: 148
Registriert: 14.04.2016, 17:23
Wohnort: Zürcher Oberland

Re: LM317 rauscht.

Beitragvon alterhase » 25.11.2016, 21:22

...Jo,Himmiherrgottsakrakruzefixhallegiedenscheissglumpellendigesübaranander mei Glaskugel iss verreckt. 8)
Löten verbindet ...manchmals. :mrgreen:
73 55
alterhase
 
Beiträge: 12046
Registriert: 14.11.2008, 08:58
Wohnort: Wien/Kapfenberg

Re: LM317 rauscht.

Beitragvon Mathias » 26.11.2016, 18:20

Der Elko hat nichts gebracht.

Ich habe jetzt Widerstände reingemacht, welche 2V am Ausgang erzeugen.
Jetzt habe ich eine saubere Spannung.
Ich habe jetzt den Gain des ADS1115 auf 2,048 V eingestellt, vorhin hatte ich 4,096V.
Mathias
 
Beiträge: 148
Registriert: 14.04.2016, 17:23
Wohnort: Zürcher Oberland

Re: LM317 rauscht.

Beitragvon alterhase » 27.11.2016, 06:41

...also zu wenig Regelreserve gehabt.

Freut mich wenns jetzt klappt. :D
Löten verbindet ...manchmals. :mrgreen:
73 55
alterhase
 
Beiträge: 12046
Registriert: 14.11.2008, 08:58
Wohnort: Wien/Kapfenberg

Re: LM317 rauscht.

Beitragvon Mathias » 27.11.2016, 19:24

Danke für deine Hilfe, man lernt immer dazu. :wink:
Mathias
 
Beiträge: 148
Registriert: 14.04.2016, 17:23
Wohnort: Zürcher Oberland


Zurück zu Bauteile

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron